US Region SFTP Server - Authentication Issues

Incident Report for Wellspring Services Status Page

Resolved

The service has remained stable since restoration. This incident is now closed.
Posted Aug 09, 2025 - 06:43 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 08, 2025 - 12:31 UTC

Monitoring

We have resolved the recent authentication issue impacting SFTP access. All systems are operational and authentication has been restored. We will continue to monitor the system and related services to make sure SFTP connectivity runs smoothly. If you run into any further issues, please reach out to our Application Support team.
Posted Aug 08, 2025 - 12:30 UTC

Identified

We have identified a networking/DNS issue affecting authentication to the SFTP server. Our team is actively investigating and working to resolve the issue. Further updates will be provided as we make progress.
Posted Aug 08, 2025 - 11:46 UTC

Investigating

Users using the SFTP server in the US region are experiencing authentication issues connecting to the SFTP server.

Our team is investigating the root cause and working to restore full connectivity as quickly as possible. Updates will be posted as progress is made.
Posted Aug 08, 2025 - 11:16 UTC
This incident affected: Integrations and Components (Wellspring SFTP - FilesEU).