The incident has been resolved, and no further outages or issues have occurred since services were restored. We will continue to monitor, but no further impact is expected.
Posted Aug 07, 2025 - 07:09 UTC
Monitoring
All services in the KSA region have been restored. We will continue to monitor the situation to ensure stability.
Posted Aug 06, 2025 - 16:02 UTC
Identified
Services are currently being restored. Our colocation datacenter provider was conducting unexpected emergency maintenance on their network, which impacted availability in the KSA region. We are actively monitoring the situation and will provide further updates as needed.
Posted Aug 06, 2025 - 15:11 UTC
Investigating
We are currently investigating an outage impacting the Accolade Cloud platform in the KSA region. Users in this region may be unable to access services at this time. Our team is actively working to identify the cause and restore functionality as quickly as possible.
We will provide an update as soon as more information becomes available.