Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 16, 2025 - 06:00 UTC
Scheduled
Our HC2 colocation datacenter provider will be conducting planned maintenance to enhance network infrastructure and reliability, possibly impacting our Accolade Cloud - EMEA systems. Please find the details below:
Planned Maintenance Window: - Start: Wednesday, July 16, 2025 – 20:00 CEST - End: Wednesday, July 16, 2025 – 22:00 CEST
During this period, you may experience brief interruptions to network connectivity as their team performs the work. This scheduled maintenance, outside of our normal window, is necessary to improve the stability and reliability of the colocation provider’s infrastructure.
We understand how important our services are to your operations and apologize for any inconvenience this may cause. Our team will closely monitor the maintenance and ensure everything is restored promptly if needed.
We appreciate your understanding and cooperation. If you have any questions or concerns regarding this maintenance, please don’t hesitate to reach out to our support team at support.emea@wellspring.com
Posted Jul 14, 2025 - 08:50 UTC
This scheduled maintenance affected: Accolade Cloud (Accolade Cloud - EMEA).