Accolade Cloud - Azure Hosted Environments

Incident Report for Wellspring Services Status Page

Resolved

Resolved – The global connectivity incident affecting Accolade Cloud services has been fully resolved.

Our upstream provider, Cloudflare, has confirmed that the root cause was an internal software configuration error within their Bot Management system (specifically, a malformed feature file that exceeded system memory limits). They have explicitly confirmed this was not a cyber-attack.

We have observed stable connectivity across all environments (Accolade Azure/KSA) since 14:30 UTC, and Cloudflare has declared all their systems fully operational as of 17:06 UTC.

This incident is now closed.
Posted Nov 19, 2025 - 07:35 UTC

Update

Update – We are observing a return to normal service stability across all affected environments.

Cloudflare has confirmed that a fix has been implemented and they are currently monitoring the results. Consequently, we are downgrading the incident status to Degraded Performance while we continue to verify that the stability is sustained.
Posted Nov 18, 2025 - 16:45 UTC

Monitoring

Update – Connectivity to accolade.net environments remains intermittent as the upstream network stabilizes.

Cloudflare has updated their status to confirm the issue is Identified and that a fix is currently being implemented across their global network. We are monitoring the situation closely and expect stability to improve as their remediation takes effect.
Posted Nov 18, 2025 - 13:13 UTC

Update

Update – Despite earlier signs of recovery, we are currently observing a recurrence of connectivity issues and increased error rates.

Please note that this incident is specifically impacting environments hosted on the accolade.net domain.

It appears that the stability of the Cloudflare network is fluctuating. We are maintaining the current incident status and monitoring the situation closely as the upstream provider works to permanently resolve the root cause
Posted Nov 18, 2025 - 12:54 UTC

Update

Update – Despite earlier signs of recovery, we are currently observing a recurrence of connectivity issues and increased error rates.

Please note that this incident is specifically impacting environments hosted on the accolade.net domain.

It appears that the stability of the Cloudflare network is fluctuating. We are maintaining the current incident status and monitoring the situation closely as the upstream provider works to permanently resolve the root cause.
Posted Nov 18, 2025 - 12:53 UTC

Identified

We are currently investigating reports of access issues affecting some Accolade Cloud instances. Users may encounter "500 Internal Server Error" messages or Cloudflare-branded error pages when attempting to log in or navigate the system.

This issue has been identified as a global network incident affecting our upstream provider, Cloudflare. This is not an issue with the Accolade application itself, but rather the secure delivery network used to reach it.

Cloudflare is currently investigating the root cause. We are monitoring their progress closely and will provide an update as soon as connectivity is restored.
Posted Nov 18, 2025 - 12:08 UTC

Investigating

We've detected an incident and are currently investigating the issue. Our team is actively working to determine the cause and scope of the problem.

We'll provide updates as soon as we have more information.
Posted Nov 18, 2025 - 12:08 UTC
This incident affected: Accolade Projects (Accolade Projects - US, Accolade Projects - EMEA), Accolade Cloud (Accolade Cloud - KSA, Accolade Cloud - APAC, Accolade Cloud - Azure), and Integrations and Components (Single Sign-On - FSUS, Single Sign-On - FSEU, Single Sign-On - FSAU).